Getting errors in Admin general settings

I must create subcategories below the top level category and add there. Is this a bug or by design?

v3.9.0 stable

Disregard. I found the parent directory listing enable under general settings. I am however getting errors on the results page when saving new general settings, although the settings do stick when I click back.

Warning : join(): Invalid arguments passed in ~/oc-admin/controller/settings/main.php on line 52

Warning : Cannot modify header information - headers already sent by (output started at ~/oc-includes/osclass/utils.php:2184) in ~/oc-includes/osclass/utils.php on line 2189

It may be a plugin or theme issue. Did you tried disabling all plugins and themes and check logs again?

Yes, I just tried not only disabling added plugins but also deleting them. Interestingly, when I enable the Omega admin theme, I get this error at the bottom of the general settings page before clicking save. In fact, there is no button at all to save.

Fatal error : Call to undefined function osc_market_api_connect() in ~/oc-admin/themes/omega/settings/index.php on line 325

Also worth noting is Settings/General is the only admin page affected. Everything else seems to work fine. Disabling Admin theme plugin also does not fix the problem. Do I assume you get no similar errors on the general settings page? This is a new install so I’m not 100% opposed to starting over again. My thought being I did once try to install the Omega admin theme from the main theme installer and it created errors. Maybe something is corrupted in the mySQL database?

So, I looked at the lines of code referenced in the error messages. Omega admin theme is making a call to the osclass market which, as I understand it, is broken. Patched it by deleting lines 325-338. I fixed all the footer external links that point to osclass.org by updating ~/oc-admin/themes/omega/functions.php lines 107-110.

    <a title="<?php _e('Osclass'); ?>" href="https://github.com/navjottomer/Osclass/" target="_blank"><?php _e('Osclass'); ?> v<?php echo preg_replace('|.0$|', '', OSCLASS_VERSION); ?></a> / 
    <a title="<?php _e('Documentation'); ?>" href="https://osclass.gitbook.io/osclass-docs/" target="_blank"><?php _e('Documentation'); ?></a> / 
    <a title="<?php _e('Forums'); ?>" href="https://osclass.discourse.group/" target="_blank"><?php _e('Forums'); ?></a> / 
    <a title="<?php _e('Feedback'); ?>" href="https://github.com/navjottomer/Osclass/issues/" target="_blank"><?php _e('Feedback'); ?></a>

I was also able to patch the Modern admin theme by commenting out the autoupdate function on line 52 of ~/oc-admin/controller/settings/main.php. The general settings page no longer produces errors. I’ll continue to use this temporary fix until the autoupdate feature has been ported over successfully to this new fork.

Z